Welcome, Guest. Please Login or Register
UGENE Bulletin Board
  Welcome to our forum.
  HomeHelpSearchLoginRegister  
 
 
Page Index Toggle Pages: 1
Problem running 64bit linux ugene (Read 19761 times)
Apr 9th, 2012 at 8:54pm

Rosz   Offline
YaBB Newbies

Posts: 3
*
 
Hi all,

I've downloaded the latest 64bit linux Ugene (ugene-1.10.4-x86-full.tar.gz), unpacked it and when I tried to launch it I got the following errors:
Code:
$ ./ugene -ui
/mnt/ris-fas1a/linux_users2/hzen/bin/software/ugene/ugene-1.10.4/ugeneui: /usr/lib64/libz.so.1: no version information available (required by /mnt/ris-fas1a/linux_users2/hzen/bin/software/ugene/ugene-1.10.4/libU2Core.so.1)
/mnt/ris-fas1a/linux_users2/hzen/bin/software/ugene/ugene-1.10.4/ugeneui: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /mnt/ris-fas1a/linux_users2/hzen/bin/software/ugene/ugene-1.10.4/libU2Core.so.1)
/mnt/ris-fas1a/linux_users2/hzen/bin/software/ugene/ugene-1.10.4/ugeneui: /lib64/libc.so.6: version `GLIBC_2.9' not found (required by /mnt/ris-fas1a/linux_users2/hzen/bin/software/ugene/ugene-1.10.4/libQtGui.so.4)
/mnt/ris-fas1a/linux_users2/hzen/bin/software/ugene/ugene-1.10.4/ugeneui: /lib64/libc.so.6: version `GLIBC_2.9' not found (required by /mnt/ris-fas1a/linux_users2/hzen/bin/software/ugene/ugene-1.10.4/libQtCore.so.4)
 



Following are the information of the above lib64 files:

Code:
$ file /usr/lib64/libz.so.1
/usr/lib64/libz.so.1: symbolic link to `libz.so.1.2.3'

$ file /usr/lib64/libstdc++.so.6
/usr/lib64/libstdc++.so.6: symbolic link to `libstdc++.so.6.0.8'

$ file /lib64/libc.so.6
/lib64/libc.so.6: symbolic link to `libc-2.5.so'
 



I've tried to google around for these error but it is getting me nowhere.

I'm running scientific linux which is basically a redhat linux. And unfortunately I'm not exactly a linux guru either  Embarrassed Any help will be greatly appreciated. Thank you.

 
IP Logged
 
Reply #1 - Apr 10th, 2012 at 4:01pm

German   Offline
Full Member

Posts: 118
***
 
Rosz, could you tell us please what operating system you use? Probably, we know what is the problem, but we need to be sure.
 
IP Logged
 
Reply #2 - Apr 11th, 2012 at 4:51am

Rosz   Offline
YaBB Newbies

Posts: 3
*
 
I'm running scientific linux 5.4 which is based on redhat.

Thank you.
 
IP Logged
 
Reply #3 - Apr 26th, 2012 at 9:26pm

Rosz   Offline
YaBB Newbies

Posts: 3
*
 
I have 16GB of RAM
 
IP Logged
 
Reply #4 - May 10th, 2012 at 4:31pm

Agu   Offline
Junior Member
(Argentinian)

Gender: male
Posts: 63
**
 
Hi, Rosz.

Did you have an older version working? I ask you that because I had a similar problem in ubuntu, and the solution was to delete all the files in the previous version before extracting the new files to that folder.
So, if your working ugene is in
/mnt/ris-fas1a/linux_users2/hzen/bin/software/ugene/
Then try deleting everything in that folder and then extract the new files (directly to the ugene folder and not creating a subfolder like 'ugene-1.10.4').
 
IP Logged
 
Reply #5 - Jul 25th, 2012 at 9:55pm

Qubert   Offline
YaBB Newbies

Posts: 3
*
 
Hello,

I'm having nearly the same problem.
The OS is CentOS 5.2 (redhat-based) with kernel 2.6.18.
I used ugene-1.11.0 and it is installed for the first time.

when I start ugene I get the following message:
Code:
$ ./ugene -ui
/ugene-1.11.0/ugeneui: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /ugene-1.11.0/libU2Core.so.1)
/ugene-1.11.0/ugeneui: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /ugene-1.11.0/libU2Core.so.1)
/ugene-1.11.0/ugeneui: /lib64/libc.so.6: version `GLIBC_2.7' not found (required by /ugene-1.11.0/libU2Algorithm.so.1)
/ugene-1.11.0/ugeneui: /lib64/libc.so.6: version `GLIBC_2.9' not found (required by /ugene-1.11.0/libQtGui.so.4)
/ugene-1.11.0/ugeneui: /lib64/libc.so.6: version `GLIBC_2.11' not found (required by /ugene-1.11.0/libQtGui.so.4)
/ugene-1.11.0/ugeneui: /lib64/libc.so.6: version `GLIBC_2.10' not found (required by /ugene-1.11.0/libQtNetwork.so.4)
/ugene-1.11.0/ugeneui: /lib64/libc.so.6: version `GLIBC_2.9' not found (required by /ugene-1.11.0/libQtCore.so.4)
 



libstdc++:
Code:
$ strings /usr/lib64/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_FORCE_NEW
 



libc:
Code:
$ strings /lib64/libc.so.6  | grep GLIBC  
GLIBC_2.2.5
GLIBC_2.2.6
GLIBC_2.3
GLIBC_2.3.2
GLIBC_2.3.3
GLIBC_2.3.4
GLIBC_2.4
GLIBC_2.5
GLIBC_PRIVATE
 



So the 'universal binary package' does not work.

So I compiled it on Ubuntu and copied it to CentOS 5.2 but it didn't work because of:
Code:
$ ./ugene -ui
myUgene/ugeneui: error while loading shared libraries: myUgene/libU2Core.so.1: ELF file OS ABI invalid

$ readelf -h libU2Core.so
ELF Header:
  Magic:   7f 45 4c 46 02 01 01 03 00 00 00 00 00 00 00 00
  Class:                             ELF64
  Data:                              2's complement, little endian
  Version:                           1 (current)
  OS/ABI:                            UNIX - Linux
  ABI Version:                       0
  Type:                              DYN (Shared object file)
  Machine:                           Advanced Micro Devices X86-64
  Version:                           0x1
  Entry point address:               0x7f6c0
  Start of program headers:          64 (bytes into file)
  Start of section headers:          1930840 (bytes into file)
  Flags:                             0x0
  Size of this header:               64 (bytes)
  Size of program headers:           56 (bytes)
  Number of program headers:         7
  Size of section headers:           64 (bytes)
  Number of section headers:         31
  Section header string table index: 28
 


maybe I could change the spec for the QT-Project to compile it for CentOS where I need OS/ABI: UNIX - System V instead of OS/ABI:UNIX - Linux.

any help would be appreciated.
 
IP Logged
 
Reply #6 - Jul 26th, 2012 at 5:16pm

Qubert   Offline
YaBB Newbies

Posts: 3
*
 
I found a solution to compile ugene for CentOS 5.1:

Install CentOS 5.1 in a virtual machine i.e. virtualbox.

Start CentOS in virtualbox and install new Qt-dev packages [http ://joseph.freivald.com/linux/2010/02/25/qt-4-6-2-packages-for-centos-5-4/] (please remove the <space> after http, because I'm not allowed to post links):
Code:
$ rpm -ivh http ://software.freivald.com/centos/software.freivald.com-1.0.0-1.noarch.rpm
$ export PATH=$PATH:/usr/lib64/qt4/bin/
 



Download, unpack, configure and compile ugene:
Code:
$ cd ~/ugene
$ wget http ://ugene.unipro.ru/downloads/ugene-1.11.0.tar.gz
$ tar xfv ugene-1.11.0.tar.gz
$ cd ~/ugene/ugene-1.11.0
$ qmake CONFIG+=x64 -r
$ make
 



Copy some Qt-libs to ~/ugene/ugene-1.11.0/src/_release
(libQtWebKit.so.4, libQtCore.so.4, libQtGui.so.4, libQtNetwork.so.4, libQtOpenGL.so.4, libQtScript.so.4, libQtSvg.so.4, libQtXmlPatterns.so.4, libQtXml.so.4)

Now you can use the folder _release and copy it to desired CentOS and start ugene...
 
IP Logged
 
Page Index Toggle Pages: 1