Welcome, Guest. Please Login or Register
UGENE Bulletin Board
  Welcome to our forum.
  HomeHelpSearchLoginRegister  
 
 
Page Index Toggle Pages: 1
Problem with qt 4.5.2 (Read 9627 times)
Sep 8th, 2009 at 4:58pm

edoardo   Offline
YaBB Newbies

Posts: 1
*
 
Hi,
I've recently installed the latest 1.5 version of Ugene on my Ubuntu 9.04 system. No problem with the installation but when I try to start the program I receive this error message: Executable 'UGENE' requires Qt 4.5.2 found Qt 4.5.1
So I went to qt official site (qt.nokia.com) and downloaded the latest 4.5.2 version of the package. Following the instruction on the site I've compiled and installed this new version and all seems to be fine, but the error message at Ugene start still there and I can't use the program. Since I'm quite new to linux system I think I've missed something during Qt installation.
How can I solve this problem? Is there something more to do to make Ugene recognise the new Qt package I've installed?
Thanks for all your suggestions!
Edoardo
 
IP Logged
 
Reply #1 - Sep 10th, 2009 at 3:37pm

Ivan Efremov   Offline
YaBB Administrator
Novosibirsk

Gender: male
Posts: 46
*****
 
Hi Eduardo,
This is a known issue - UGENE needs Qt which is not younger than Qt which was used for build process. In the next release we will workaround the issue.

For now, just try to add path to the new Qt binaries to LD_LIBRARY_PATH environment variable.
For example:

export LD_LIBRARY_PATH=/usr/local/Trolltech/Qt-4.5.2/lib:$LD_LIBRARY_PATH
 

UGENE team
IP Logged
 
Reply #2 - Mar 18th, 2010 at 3:29pm

Samia   Offline
YaBB Newbies

Posts: 1
*
 
hi, i am having problem with running ugene. i had the similar problem as above.
Executable 'ugene' requires Qt 4.5.2, found Qt 4.5.0.
i tried that command in the above post. but it didn't work. can u please help me????? Sad Cry Shocked
 
IP Logged
 
Reply #3 - Mar 18th, 2010 at 4:25pm

Mikhail Fursov   Offline
YaBB Administrator

Gender: male
Posts: 162
*****
 
Hi Samia,

Here some details about the problem in general:

UGENE normally uses a QT version shipped with upcoming Linux distro in Ubuntu and Fedora words. Now it's 4.6.2 so we test UGENE with it and make dependency on it.

It's not always possible to test UGENE with the previous QT version and claim that it will work with the latter one. A good example is the recent change in Qt 4.6 with graphics scene mode that made UGENE that worked with 4.5.x fine to fail with Qt 4.6

In your case there are several options:

1) Update QT libraries to the latest version. Probably you will need to use a special Linux distribution mirror to access to it.

2) Lower QT version dependancy in UGENE sources and build UGENE form the source

3) Install prebuilt QT4.6.2 snapshot from http://qt.nokia.com, modify ugene running script to using it. (by adding Qt4/bin to the PATH and LD_LIBRARY_PATH variable

4) Wait until the next release (v1.6.2) that will be released next week. With this release we plan adding a prebuilt version for 32 and 64 bit Linux that should work on all modern Linux versions. All you will need is just to unpack it to some folder.

If you checked any of these recipes and the recipe doesn't work for you, please provide us with step-by-step details of what you did, so we can provide more detailed support.
« Last Edit: Mar 19th, 2010 at 2:06pm by Konstantin Okonechnikov »  

---
UGENE team
IP Logged
 
Page Index Toggle Pages: 1